Адаптер tp-link tl-wn822n и ядро linux выше 5.10

1 min


АДАПТЕР TP-LINK TL-WN822N vs LINUX UBUNTU

Есть отличный адаптер TP-LINK TL-WN822N v.5 который работает на чипсете RTL8192EU. На ядре ниже 5.0 с ним проблемы нет — он отлично работает во всех режимах. Если системат обновлена, то драйвер для чипсета не работает.

Долго ломал голову, пока не набрел сюда.

TP-LINK TL-WN822N и LINUX UBUNTU​ с ядром 5.0+

Before installing

Сначала проверить наличие необходимого.

Проверка:

sudo apt list linux-headers-generic build-essential dkms git

Установим недостающее:

sudo apt -y install linux-headers-generic build-essential dkms git

Скачиваем с репозитория:

https://github.com/clnhub/rtl8192eu-linux

https://github.com/clnhub/rtl8192eu-linux/archive/refs/heads/master.zip

Автоматическая установка

Запуститьв дирректории с драйвером:

./install_wifi.sh

Manual install

Remove available drivers with (skip if sudo lshw -C network and dkms status do not show any wifi drivers):

sudo rmmod 8192eu
sudo rmmod rtl8xxxu
sudo dkms remove rtl8192eu/1.0 --all

Blacklist default driver (rtl8xxxu on Ubuntu):

echo "blacklist rtl8xxxu" >> ./blacklist-rtl8xxxu.conf
sudo mv ./blacklist-rtl8xxxu.conf /etc/modprobe.d/

Run add and install commands from driver directory:

sudo dkms add .
sudo dkms install rtl8192eu/1.0

Load driver (or reboot):

sudo modprobe 8192eu

После этого адаптер в качестве точки доступа заработал.

0

Share via
>